Oznámení

Sbalit
Aktuálně žádná oznámení.

HippoPlayer

Sbalit
X
 
  • Filtr
  • Čas
  • Zobrazit
Vymazat vše
new posts

    HippoPlayer

    Tak to vypada, ze se po vice jak 21 letech (zatim posledni verze 2.45 byla nahrana na Aminet 7.1.2000) dockame nove verze oblibeneho mod playeru HippoPLayer.
    Puvodni autor Kari-Pekka Koljonen se vraci ke svemu ditku a pracuje na opravach starych chyb a vylepsenich.

    Zdrojove kodu jsou k dispozici uz nejaky ten cas na GitHubu https://github.com/koobo/HippoPlayer

    Pripravovana verze 2.46 (zatim beta) obsahuje nasledujici zmeny
    • Extraneous requester pop up removed when loading TFMX modules.
    • Fixed a case where unpacked modules were not identified as modules, or a non-module file was identified as a valid module (due to badly initialized memory).
    • A memory leak removed from the file requester.
    • Memory usage is lowered in several situations:
      • Random play bookkeeping now uses a dynamically allocated table.
      • Each modulelist entry is now about 30 bytes smaller, for 1000 modules that means memory savings of about 30 kB!
      • Unnecessary library loading removed from startup. This also speeds up starting on slow machines.
    • Improved stability
      • Starting and stopping playback and loading modules like a crazy person is now not so prone to crashing. This is achieved by adding exclusive access checks to module data and module list in several places (see above).
    • Other general bad behaviour removed from many places, not directly visible to user.
    • May survive low memory situations better when loading module programs or adding files.
    • A bunch of smaller fixes, such as enforcer hit removals at a few places.
    • Code refactoring! It's still quite a mess in many places.
    Naposledy upravil ExiE; 16.06.2021, 12:47:59. Důvod: Amiga 68k, HippoPlayer, mod player

    #2
    Tak hlavně aby to už fungovalo s DefIcons
    Amiga 4000D - CyberStorm MKIII 060@50 Mhz, Sonnet G3@400, 64 + 128 MB Fast, OS 3.9, Mediator, Voodoo3, SB128
    Amiga 1200T - Z4 Tower, Apollo 1260@50, 64 MB RAM, FastATA, Mediator, R9200, LAN, USB, TV

    Komentovat


      #3
      Pro mně je nejdůležitější stabilita přehrávání MODů. Je fajn, že si na netu můžu najít verzi MODu, kterou mi HippoPlayer, nebo EaglePlayer přehraje dobře, ale za stavu kdy si s problémovým MODem pořadí Octamed a HP, nebo EP ne, jsou tyhle dva playere není na úrovni Octamedu. EP je na tom o něco lépe vůči HP díky poslední verzi i když ta poslední verze EP vůči její předchozí verzi je v některých aspektech míň ohrabaná.
      Amiga - PMD 85

      Komentovat


        #4
        Autorem citovaného textu je Lisiak4 Přejít na původní příspěvek
        Pro mně je nejdůležitější stabilita přehrávání MODů. Je fajn, že si na netu můžu najít verzi MODu, kterou mi HippoPlayer, nebo EaglePlayer přehraje dobře, ale za stavu kdy si s problémovým MODem pořadí Octamed a HP, nebo EP ne, jsou tyhle dva playere není na úrovni Octamedu. EP je na tom o něco lépe vůči HP díky poslední verzi i když ta poslední verze EP vůči její předchozí verzi je v některých aspektech míň ohrabaná.

        Naposledy upravil Predseda; 17.06.2021, 10:24:02.
        Do ženský, do motoru a do budov v Syndicate nevidíš.

        Komentovat


          #5
          Autorem citovaného textu je Lisiak4 Přejít na původní příspěvek
          Pro mně je nejdůležitější stabilita přehrávání MODů. Je fajn, že si na netu můžu najít verzi MODu, kterou mi HippoPlayer, nebo EaglePlayer přehraje dobře, ale za stavu kdy si s problémovým MODem pořadí Octamed a HP, nebo EP ne, jsou tyhle dva playere není na úrovni Octamedu. EP je na tom o něco lépe vůči HP díky poslední verzi i když ta poslední verze EP vůči její předchozí verzi je v některých aspektech míň ohrabaná.
          Zajimavy nazor, pane premiere
          Nevim jestli narazis na mozne problemy s casovanim podle VBlank misto CIA, nebo v tom je jeste neco dalsiho, ale pokud takovy spatne hrajici mod mas, je idealni doba ho submitnout autorovi...

          Komentovat


            #6
            Autorem citovaného textu je TheMrKocour Přejít na původní příspěvek
            Tak hlavně aby to už fungovalo s DefIcons
            Stále to nefunguje, ani z AmiDocku
            Amiga 4000D - CyberStorm MKIII 060@50 Mhz, Sonnet G3@400, 64 + 128 MB Fast, OS 3.9, Mediator, Voodoo3, SB128
            Amiga 1200T - Z4 Tower, Apollo 1260@50, 64 MB RAM, FastATA, Mediator, R9200, LAN, USB, TV

            Komentovat


              #7
              ExiE, celkově byli ty MODy asi 3, jedná se o vicepatternové módy, tedy 16 a více patternů, kdy po nějakém patternu se přešlo v rámci MODu na nesmyslně pomalé přehrávání skladby. Jeden ze známých MODů je Settlers u kterého jsem si stáhl i verzi, která je OK, ale tu špatnou verzi Octamed zahraje dobře. Jednoduše se při nějaké kombinaci v rámci editace MODu přepíše v playeru rychlost hraní skladby na špatnou. Pak se začne MOD hrát hodně pomalým tempem. Poslední verze EP vyřešila jeden MOD z těch 3 a již to tuhle chybu přestalo dělat. Já teď ty další 2 skladby z hlavy nedám. Pro mně to není zásadní problém, jen o něm vím. Můžu MOD Settlers poskytnout, ale psát autorovi nebudu. Já v hlavě v rámci Amigy řeším jiné věci v rámci programování. Ano je tam i možnost, že jsou ty MODy editované ne zcela standardně a Octamed to jednoduše nějak lépe pobere možná i díky tomu, že samotné skladby mohli být v Octamedu editovány, neříkám že ne. S formátem MOD se seznamují postupně.
              Amiga - PMD 85

              Komentovat


                #8
                Tohle ale asi není chyba modu, to je asi chybka ve Tvém programu. Jak ten mod dávají jiné přehrávače než jen Octamed?
                Amiga 600, Fúria EC020 OS 3.1.4, eX601, Indivision ECS,
                Powerbook G4, 1.67GHz, MOS3.15, Asus UX32VD Xubuntu 21.04

                Komentovat


                  #9
                  Nebavím se o mém programu, ten nepracuje s formátem MOD. Jiné playere ten MOD přehrají tak jak jsem napsal.
                  Amiga - PMD 85

                  Komentovat


                    #10
                    No jo, takže chybka v MODu, sory.
                    Amiga 600, Fúria EC020 OS 3.1.4, eX601, Indivision ECS,
                    Powerbook G4, 1.67GHz, MOS3.15, Asus UX32VD Xubuntu 21.04

                    Komentovat


                      #11
                      Nojo, ale takové lapálie, že soubor v něčem otevřít jde a jinde ne se obvykle berou jak říká Lisiak4 - jako chyba softwaru, nikoli souboru.
                      AmigaOS: Pegasos II, Sam440ep-flex, Micro A1-C, AmigaOneX1000
                      MorphOS: Efika, Pegasos II, Powerbook G4, iMac G5, Powermac G5 Quad

                      Komentovat


                        #12
                        Asi teda jo, měl jsem dojem že Lišák psal o dvou verzích toho settlers MODu, (mimo jiné).
                        Amiga 600, Fúria EC020 OS 3.1.4, eX601, Indivision ECS,
                        Powerbook G4, 1.67GHz, MOS3.15, Asus UX32VD Xubuntu 21.04

                        Komentovat


                          #13
                          Ano, ale Octamed obě verze přehraje správně. Ono rychlost hraní MODu je asi nejtěžší uhlídat jako parametr vnitřně v programu. Zatím asi jediný parametr který se nemusí zadávat na každém řádku v patternu. Třeba hlasitost pokud není zadaná se nastavuje automaticky na 3/4 tedy 30 hexa z celkových 40 hexa. Sampl musíš opakovat i když použiješ ten který již máš nahraný v HW registru. Myslím že frekvenci taky. Myslím že všechny údaje se v MODu zadávají v každém řádku patternu nanovo, kromě té rychlostí hraní skladby.
                          Amiga - PMD 85

                          Komentovat


                            #14
                            Takže dva MODy jeden s chybným nebo chybějícím parametrem?
                            Víkend mám slaměný, tak asi začnu studovat manuál.
                            Amiga 600, Fúria EC020 OS 3.1.4, eX601, Indivision ECS,
                            Powerbook G4, 1.67GHz, MOS3.15, Asus UX32VD Xubuntu 21.04

                            Komentovat


                              #15
                              The DefIcon problem is technically similar to the command line problem from shell:
                              - No HiP running
                              - cd <path 1>
                              - HiP <module filename without path>
                              -
                              - cd <path 2>
                              - HiP <another module filename without path>
                              - , since the running HiP current path is set to <path 1> and <another module> can't be found

                              Anyhow, I fixed this problem, although it won't work on kick1.3 since that would've been too painful to implement

                              EDIT: Forgot to mention that drag-and-drop module icon into HiP window is not related directly related the DefIcons launch case.

                              Komentovat

                              Zpracovávám...
                              X