Oznámení

Sbalit
Aktuálně žádná oznámení.

Oživení A1200 akcelerátoru

Sbalit
X
 
  • Filtr
  • Čas
  • Zobrazit
Clear All
new posts

    Oživení A1200 akcelerátoru

    Ahoj,
    je tu někdo, kdo by mi poradil s opravou turbíny Apollo 1230MkIII, viz
    https://www.bigbookofamigahardware.com/ ... spx?id=109 ?
    Koupil jsem ji na eBay jako nefunkční s tím, že vizuelně měla poškrábané cesty na spodku PCB.
    Karta přišla, tak jsem se do ní pustil a co jsem zvládl jsem na ni učesal: očistil a přecínoval ten škrábanec, cesty jsem prozvonil a jsou všechny ok. Našel jsem rozlomenou SMD odporovou řadu - vyměněno, oměřeno, ok. Vypáral jsem PGA 030 CPUčko, protože pod ním bylo PCBčko viditelně dlouhodobětepelně namáhané - proměřil jsem pod ním zkusmo pár (cca. 20) cest, zejména ty s prokovy, pak osadil patici a do ní nové CPU. Vypáral jsem a vyměnil pro jistotu RAM patici, na kterou někdo útočil s pájkou. Vyměnil jsem i trascievery 74ACT16543, prostě protože jsem je měl v šuplíku. Sundal jsem a přečetl EPROMku a GAL, obojí jde přečíst a obsah vypadá na první pohled rozumně. Přesadil jsem v patici obě dvě MACH PLCčka, ty ale bohužel nedokážu v mém programátoru přečíst. Desku jsem dál komplet projel pod mikroskopem, nenašel jsem nic dalšího.
    Změřil jsem oscilátor, který je napájený dává krásných 40mega. Kartu jsem pak zkusil rozjet s ním i s 32mega krystalem. Zkontroloval jsem a isopropylem vyčistil konektor.
    Zkoušel jsem to s i bez paměti, dá se jumperem zakázat. A to je asi tak všechno, co s tím bez dalších informací dokážu udělat.

    Ale i přes tuhle všechnu snahu karta nejede, pořád jenom černá obrazovka. Nezinicializuje to ani Diagrom. Amiga samotná je funkční a stabilní s jinou turbínou (Apollo 1220/4).
    Hledal jsem k té 1230ce schema, bohužel není. A já ani nemám s tímhle HW žádné praktické zkušenosti, nevím jak to dál debugovat. Nevím ani jaký je mechanizmus přepnutí z interního CPU na CPU akcelerátoru.
    Ocením jakoukoliv radu k věci.

    Pavel

    #2
    O: Oživení A1200 akcelerátoru

    poradit ti nemam co, jen mozna prolitni tohle
    http://eab.abime.net/showthread.php?t=41476&page=2

    ty karty mely asi v nekterych pripadech to CPU pretaktovano opravdu hodne a mozna to casem radeji vzdaly

    Komentovat


      #3
      O: Oživení A1200 akcelerátoru

      Osciloskop máš...?
      AmigaServiceMan

      Komentovat


        #4
        O: Oživení A1200 akcelerátoru

        Dvoukanál, 100MHz

        Komentovat


          #5
          O: Oživení A1200 akcelerátoru

          Tak si zkoukni, jestli krystal na turbíně dává, co má a jestli je to OK, tak si podle tohodle videa :



          zrob jednoduchou near-field probes (teda, pokuď nemáš origo...) a zprobuj...

          AmigaServiceMan

          Komentovat


            #6
            O: Oživení A1200 akcelerátoru

            Oscilátor dává stabilní sinusovku, která proleze přes odpor 10R na patici CPUčka, v příloze je to co jsem naměřil na pinu E1 (CLK).
            Sondy si budu muset vyrobit, to mi chvilku zabere
            Není někde na netu pinout toho 150p rozšiřujícího konektoru A1200, že bych ještě propípal to co půjde?
            Přiložené soubory

            Komentovat


              #7
              O: Oživení A1200 akcelerátoru

              http://www.amigapcb.org/
              Powerbook 17" G4 / 1.67GHz + Ati Mobility 9700 128bit + MorphOS 3.11 + MAC OS X 10.5.8+ LubuntuPPC 16.04
              Amiga 1240 / 25MHz + PPC603 / 210Mhz + AGA + 64MB_FastRam, AOS3.1, 8GB_CF, FastATA
              Amiga 600 + Furia EC020 + CF + 3COM PCMCIA Network Card

              Amiga_CD32 + Paravision_SX1

              DEAD Pegasos2 G4 / 1GHz + Ati_Radeon 9250 128bit + Soudblaster live 5.1 + MorphOS_3.1 Registered
              DEAD Amiga 1260 / 66MHz + PPC603+ / 233Mhz + BVision + 128 MB_FastRam, AOS3.1, AOS3.9, AOS4.0, FastATA

              registered on
              http://amigamap.com/amiga-slovak_republic.html

              Komentovat


                #8
                O: Oživení A1200 akcelerátoru

                To jsem ale popleta. Našel jsem každopádně i přehlednější soupis na old.pinouts.ru. Teď můžu říct, že CPU má hodiny i napájení a těch pár signálů co jde z 030 CPU přímo na exp. port je průchozích.
                Taky že /RST i /BERR jsou v logické 1, což je IMO nominální stav. Nicméně taky že na osciloskopu nevidím žádnou aktivitu na /DS (data strobe) a tam si myslím by měl být čilý provoz okamžitě po připojení napájení, nemám pravdu?
                Pin 92 není připojený na odpovídající signál na CPU patici, ale na jeden z MACH210 PLCček. Začínám si myslet, že v něm bude zakopaný pes. Je to možné?
                Naposledy upravil mpattonm; 16.02.2019, 12:37:46.

                Komentovat


                  #9
                  O: Oživení A1200 akcelerátoru

                  Tady máš základní schémata a tu sondu si udělej podle toho videa z kousku stočenýho drátku a když to přiložíš na CPU a zapneš Amigu, měl by si vidět, jestli CPU jede, nebo ne. Nebo jestli se během několika sekund nehaltne. Mě tohle dělá jedna B1260, po zapnutí 3-4s jede a pak šlus, žádná aktivita. Ještě se pak podívej na power ledku, jestli po zapnutí je taková jako přichcíplá, nebo se rozsvítí naplno.
                  Ideální by bylo, ještě jedna ta samá funkční karta a vyzkoušet MACHy, jestli jsou OK. A ještě jedna technická - timing fix na desce máš...?
                  AmigaServiceMan

                  Komentovat


                    #10
                    O: Oživení A1200 akcelerátoru

                    OK. Se sondou z kusu drátu nad tou 030 nic od zapnutí nenaměřím. Prostě nesvítí, ani pikovteřinu. Víc svítí cokoliv na mainboardu, dokonce in onboard 020ka. HALT i BERR na patici 030ky jsou ale v logické 1, čili procesor zastavený není. CPU je pod napětím a hodinami, hřeje na pokojovou teplotu. Zkusil jsem i další novou 030ku, je to ale stejné.
                    Na systémovou /DS to ale ani neškrtne, takže z ROMky to určitě nezačne číst.
                    Z tohohle pohledu je asi i ten timing fix irelevantní, nicméně jsem ho už stihl udělat - nepomohlo to.

                    Komentovat


                      #11
                      O: Oživení A1200 akcelerátoru

                      Oprava: v jedné části křemíku jde na pozadí toho bílého šumu rozpoznat namodulované hodiny. Podobně jako pod oscilátorem. Ale to je opravdu jediné, co z té 030 svítí, jinak žádný provoz.
                      /RST na 030 je taky na logické 1.
                      Co je ale zajímavé je, že hned po zapnutí něco nastaví/nakurví logiku na nižších adresních bitech. A0 až cca. A9 (dál jsem už nešel, ale např A20 zůstává v nule) se po připojení na napájení zvednou na nějakou pseudoúroveň, navíc každý na jinou. Např. A0 - 1.62V, A1 - 1.38V, A2 - 2,23V... a to všechno se děje i bez CPU - s prázdnou paticí. Všechny linky těchhle adresních bitů vedou na stejný Mach čip, případně na jednu 74ku.
                      Už to tak vypadá, že bez toho Macha se neobejdu. Nemáte to někdo stažené?
                      Případně - netušíte kde to sehnat?
                      Naposledy upravil mpattonm; 16.02.2019, 16:28:12.

                      Komentovat


                        #12
                        O: Oživení A1200 akcelerátoru

                        Autorem citovaného textu je mpattonm Přejít na původní příspěvek
                        Oscilátor dává stabilní sinusovku, která proleze přes odpor 10R na patici CPUčka, v příloze je to co jsem naměřil na pinu E1 (CLK).
                        Sondy si budu muset vyrobit, to mi chvilku zabere
                        Není někde na netu pinout toho 150p rozšiřujícího konektoru A1200, že bych ještě propípal to co půjde?
                        A to je přes nějaký koďan ? Že je tam asi 3V(oprava - 6V) offset.
                        A ani ta sinusovka se mi nezdá, nemá tam být spíše obdélník ?
                        Naposledy upravil rEVERz; 16.02.2019, 17:22:27.

                        Komentovat


                          #13
                          O: Oživení A1200 akcelerátoru

                          Je to nastavené na 0,5V/dílek, takže dole je 1,6V, nahoře kolem 2.4V Z krystalového oscilátoru bez bufferu? Z toho AFAIK opravdu má lézt sinus. Si myslim

                          Komentovat


                            #14
                            O: Oživení A1200 akcelerátoru

                            Aha, neznám Hantek - ty 2V je trigger level, pardon ;-)
                            A ten průběh změřím v pondělí, já tam tuším sinus a ani ne 1Vpp nemám

                            Komentovat


                              #15
                              O: Oživení A1200 akcelerátoru

                              No to by bylo super. Měřil jsem takhle dva krystaly, 32 a 40, dávají oba stejně. Kam až se doměřím, jdou tyhle hodiny na odpor 10R, za ním je už jen proti zemi 220R. Hodnoty sedí s popisem na desce. Takhle ošetřený signál už jde rovnou na CPU a na alespoň jeden z těch Machů. Taky bych čekal, že na CPUčko půjde ošetřený přes nějaký buffer jako obdélník a ne jako sinusovka s P-P pod 1V.

                              Komentovat

                              Zpracovávám...
                              X